Klokreations

You are not connected. Please login or register

Event won't running on my map

View previous topic View next topic Go down  Message [Page 1 of 1]

1 Event won't running on my map on Tue Jun 03, 2014 5:54 am

Hellservant


Hello I'm new in this board and FEXP too.

Yes ,I read FEXP Ultimate Guide 6.2 and still encounter an unusual problem. And I really have no idea what I did wrong.

This is my map in RMXP:
This is scene in playtest:

In playtest , BGM won't load , cursor won't appear and all units won't load too (except a small shield icon that indicate boss unit).
( All unit events are copied from first default map ( TestMap BATTLE )

This is my script in "Chapter Data" script:
CHAPTER_DATA = {
   # Chapter Maps
   'Test' =>   ['Test Map',         [0, 0], []],
   'Test2' =>  ['Another Test Map', [2, 1], []],
   'C0' =>     ['Chapter 0',        [2, 1], []],
}

CHAPTER_OBJECTIVES = {
   # Chapter Maps
   'P' =>   ["Defeat all\nenemy\ncommanders", "defeat\ncondition"],
   'C0' =>   ["Seize the throne", "Nothing yet"],
}

This is my script in 'Title' script line 190 and 267:
when 0
       @map = [$data_system.start_map_id,
           [$data_system.start_x, $data_system.start_y]]
     # Also Actual Map
     when 1
       @map = [2, [1, 1]]
     # Test Map 2
     when 2
       @map = [4, [1, 1]]
     # Ctrl F the scripts
     when 3
       @map = [2, [1, 1]]
     # Chapter 0
     when 4
       @map = [7, [1, 1]]


   ary = ['Test Map 1']
   ary.push('Also Test Map 1')
   ary.push('Test Map 2')
   ary.push('Ctrl F the scripts')
   ary.push('Chapter 0')


This is my event that will link to that map:
and yes , this event is a loner in map ID:007 and that actual map is ID:006

So my problem are
1. BGM won't load
2. Unit won't load , players and enemies ( except boss icon )
3. If I copy/paste the "Chapter End" event from default map 2 ( TestMap2 BATTLE ) , the game automatical end.
4. All default maps run just fine. These only happen on my new map.

I really don't know what i did wrong , please help. Neutral

2 Re: Event won't running on my map on Tue Jun 03, 2014 1:41 pm

Hellservant


Silly me , add "BATTLE" at the end of map name and work like magic.

So problems' solved. Sorry for anyone that was dragged into this.

3 Re: Event won't running on my map on Tue Jun 03, 2014 3:35 pm

Klokinator

avatar
Admin
Haha yeah, that's a common error. Glad you got that sorted out Smile


___________________________________
http://klokreations.forumotion.com

Sponsored content


View previous topic View next topic Back to top  Message [Page 1 of 1]

Permissions in this forum:
You cannot reply to topics in this forum